1. Welcome to skUnity!

    Welcome to skUnity! This is a forum where members of the Skript community can communicate and interact. Skript Resource Creators can post their Resources for all to see and use.

    If you haven't done so already, feel free to join our official Discord server to expand your level of interaction with the comminuty!

    Now, what are you waiting for? Join the community now!

Dismiss Notice
This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Addon WolvSK (1.8-1.16.1) 1.7.2

Some small features and plugin hooks for your server

  1. omer

    omer Member

    Joined:
    Jun 19, 2017
    Messages:
    1
    Likes Received:
    0
    broadcast "%asb owner of island at victim%-%victim%-%asb team members of team of asb owner of island at victim%"

    if island owner is offline %asb team members of team of asb owner of island at victim% is <none> Why?
     
  2. mel_instagibson

    Joined:
    Feb 4, 2017
    Messages:
    71
    Likes Received:
    4
    sooo ive seen an update for 1.13 but is there a 1.13 skript version yet?
     
  3. ShaneBee

    Resource Staff Supporter + Addon Developer

    Joined:
    Sep 7, 2017
    Messages:
    2,172
    Likes Received:
    188
    No there is not.... i think he is just meaning this will work on spigot 1.13, but hasn't tested for the obvious reason of no skript yet for 1.13
     
  4. ShaneBee

    Resource Staff Supporter + Addon Developer

    Joined:
    Sep 7, 2017
    Messages:
    2,172
    Likes Received:
    188
  5. JustADev

    JustADev Well-Known Member

    Joined:
    Apr 8, 2017
    Messages:
    380
    Likes Received:
    9
    [18:06:57 INFO]: [Skript] Reloading raid.sk...
    [18:06:57 ERROR]: #!#!
    [18:06:57 ERROR]: #!#! [Skript] Severe Error:
    [18:06:57 ERROR]: #!#! Could not load raid.sk
    [18:06:57 ERROR]: #!#!
    [18:06:57 ERROR]: #!#! Something went horribly wrong with Skript.
    [18:06:57 ERROR]: #!#! This issue is NOT your fault! You probably can't fix it yourself, either.
    [18:06:57 ERROR]: #!#! You're running outdated version of Skript! Please try updating it NOW; it might fix this.
    [18:06:57 ERROR]: #!#! You may download new version of Skript at https://github.com/bensku/Skript/releases
    [18:06:57 ERROR]: #!#! You will be given instructions how to report this error if it persists with latest Skript.
    [18:06:57 ERROR]: #!#! Issue tracker: https://github.com/SkriptLang/Skript/issues (only if you know what you're doing!)
    [18:06:57 ERROR]: #!#!
    [18:06:57 ERROR]: #!#! Stack trace:
    [18:06:57 ERROR]: #!#! java.lang.ArrayIndexOutOfBoundsException: 2
    [18:06:57 ERROR]: #!#! at fr.nashoba24.wolvsk.misc.EffCreateCooldown.init(EffCreateCooldown.java:27)
    [18:06:57 ERROR]: #!#! at ch.njol.skript.lang.SkriptParser.parse(SkriptParser.java:250)
    [18:06:57 ERROR]: #!#! at ch.njol.skript.lang.SkriptParser.parse(SkriptParser.java:177)
    [18:06:57 ERROR]: #!#! at ch.njol.skript.lang.Statement.parse(Statement.java:59)
    [18:06:57 ERROR]: #!#! at ch.njol.skript.ScriptLoader.loadItems(ScriptLoader.java:975)
    [18:06:57 ERROR]: #!#! at ch.njol.skript.command.Commands.loadCommand(Commands.java:500)
    [18:06:57 ERROR]: #!#! at ch.njol.skript.ScriptLoader.loadScript(ScriptLoader.java:622)
    [18:06:57 ERROR]: #!#! at ch.njol.skript.ScriptLoader.lambda$1(ScriptLoader.java:390)
    [18:06:57 ERROR]: #!#! at ch.njol.skript.ScriptLoader.loadScripts(ScriptLoader.java:402)
    [18:06:57 ERROR]: #!#! at ch.njol.skript.ScriptLoader.loadScripts(ScriptLoader.java:435)
    [18:06:57 ERROR]: #!#! at ch.njol.skript.SkriptCommand.onCommand(SkriptCommand.java:181)
    [18:06:57 ERROR]: #!#! at org.bukkit.command.PluginCommand.execute(PluginCommand.java:44)
    [18:06:57 ERROR]: #!#! at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:141)
    [18:06:57 ERROR]: #!#! at org.bukkit.craftbukkit.v1_13_R2.CraftServer.dispatchCommand(CraftServer.java:695)
    [18:06:57 ERROR]: #!#! at org.bukkit.craftbukkit.v1_13_R2.CraftServer.dispatchServerCommand(CraftServer.java:680)
    [18:06:57 ERROR]: #!#! at net.minecraft.server.v1_13_R2.DedicatedServer.aU(DedicatedServer.java:453)
    [18:06:57 ERROR]: #!#! at net.minecraft.server.v1_13_R2.DedicatedServer.b(DedicatedServer.java:412)
    [18:06:57 ERROR]: #!#! at net.minecraft.server.v1_13_R2.MinecraftServer.a(MinecraftServer.java:831)
    [18:06:57 ERROR]: #!#! at net.minecraft.server.v1_13_R2.MinecraftServer.run(MinecraftServer.java:729)
    [18:06:57 ERROR]: #!#! at java.base/java.lang.Thread.run(Unknown Source)
    [18:06:57 ERROR]: #!#!
    [18:06:57 ERROR]: #!#! Version Information:
    [18:06:57 ERROR]: #!#! Skript: 2.3-alpha3 (OUTDATED)
    [18:06:57 ERROR]: #!#! Bukkit: 1.13.1-R0.1-SNAPSHOT
    [18:06:57 ERROR]: #!#! Minecraft: 1.13.1
    [18:06:57 ERROR]: #!#! Java: 10.0.2 (Java HotSpot(TM) 64-Bit Server VM 10.0.2+13)
    [18:06:57 ERROR]: #!#! OS: Windows 10 amd64 10.0
    [18:06:57 ERROR]: #!#!
    [18:06:57 ERROR]: #!#! Server platform: Spigot
    [18:06:57 ERROR]: #!#!
    [18:06:57 ERROR]: #!#! Current node: delete cooldown "Raid Timer" for player (raid.sk, line 27)
    [18:06:57 ERROR]: #!#! Current item: null
    [18:06:57 ERROR]: #!#!
    [18:06:57 ERROR]: #!#! Thread: Server thread
    [18:06:57 ERROR]: #!#!
    [18:06:57 ERROR]: #!#! Language: english
    [18:06:57 ERROR]: #!#! Link parse mode: DISABLED
    [18:06:57 ERROR]: #!#!
    [18:06:57 ERROR]: #!#! End of Error.
    [18:06:57 ERROR]: #!#!
    [18:06:57 INFO]: [Skript] Successfully reloaded raid.sk.

    This error occurs when I try to delete a cooldown of a player, is this fixable?
     
  6. ShaneBee

    Resource Staff Supporter + Addon Developer

    Joined:
    Sep 7, 2017
    Messages:
    2,172
    Likes Received:
    188
    "Skript: 2.3-alpha3 (OUTDATED)" Skript itself is having a LOT of issues. Hence the alpha. It is most likely caused by Skript.
     
  7. JustADev

    JustADev Well-Known Member

    Joined:
    Apr 8, 2017
    Messages:
    380
    Likes Received:
    9
    Its Minecraft 1.13, but WolvSK supports only 1.12, so do I need 1.12 spigot?
     
  8. ShaneBee

    Resource Staff Supporter + Addon Developer

    Joined:
    Sep 7, 2017
    Messages:
    2,172
    Likes Received:
    188
    I would suggest so, since Skript 2.3 is only in Alpha stage, and therefor only to be used for bug checking/reporting.
    It is not meant to be used for live/production servers.
     
  9. JustADev

    JustADev Well-Known Member

    Joined:
    Apr 8, 2017
    Messages:
    380
    Likes Received:
    9
    @ShaneBee but it says WolvSK works for 1.13.. so do I just have to wait for a stable 1.13 version of Skript?
     
  10. ShaneBee

    Resource Staff Supporter + Addon Developer

    Joined:
    Sep 7, 2017
    Messages:
    2,172
    Likes Received:
    188
    Yes!
    "it says WolvSK works for 1.13" <-- that is meaning it works against the 1.13 SpigotAPI
    "so do I just have to wait for a stable 1.13 version of Skript?" The Skript 2.3 Alpha versions are literally meant just for testing Skript itself, and reporting bugs to skript.
     
  11. Mattyb0i

    Mattyb0i Member

    Joined:
    Oct 19, 2017
    Messages:
    5
    Likes Received:
    0
    Hello.

    I want to hear, if you could add a askyblock expression a bit like "(asb|askyblock) %player%['s] team members" and "(asb|askyblock)[ team] members of team of %player%". The two expressions with teams that are currently writing the names of the members, but i want a expression where the names will be replaced with a number. Example: "Members: Mattyb0i_ and GGgaming54321 will be replaced with "Members: 2". Because there are two on the island

    I hope you understand it

    Regards Mattyb0i_
     
  12. Nashoba

    Addon Developer

    Joined:
    Jan 27, 2017
    Messages:
    42
    Likes Received:
    42
    "(asb|askyblock) %player%['s] team members" and "(asb|askyblock)[ team] members of team of %player%" return a list, so you can do
    Code (Skript):
    1. amount of asb player's team members
    to get the number of members in the player's team.
     
  13. Mattyb0i

    Mattyb0i Member

    Joined:
    Oct 19, 2017
    Messages:
    5
    Likes Received:
    0
    Thank you so much! :emoji_grinning:
     
  14. Hello, I have little suggestion to add check for player's last seen.

    Code (Skript):
    1. %player% last seen
     
  15. infered5

    infered5 Member

    Joined:
    Mar 12, 2017
    Messages:
    5
    Likes Received:
    0
    When running "set {variable} to minecraft version of player", it always seems to return version 340 when running ViaVersion regardless of what client version I am using. Is this a limitation of running Spigot 1.12.2 and ViaVersion to get future clients on there, as it doesn't know the client protocol versions of future clients such as 1.15.2's 578?
     
  16. Nashoba

    Addon Developer

    Joined:
    Jan 27, 2017
    Messages:
    42
    Likes Received:
    42
    Nashoba updated WolvSK (1.8-1.13.1) with a new update entry:

    WolvSK 1.7.0

    Read the rest of this update entry...
     
  17. Wafffidooe

    Wafffidooe Member

    Joined:
    Jul 28, 2020
    Messages:
    1
    Likes Received:
    0
    Hi

    When using Essentials' vanish effect, I happened to notice it only to work on OP players... I even tried giving nonOP players several essentials-vanish permissions without it helping the situation...

    I'm running WolvSK 1.7.0, and Skript2.5 alpha5
    Server version 1.12.2

    Other than that.. I know you're kinda not working on this addon anymore... but it would be so nice, if it was compatible with the plugin MainMC (an alternative to Essentials).
    --- Double Post Merged, Jul 31, 2020 at 9:39 AM, Original Post Date: Jul 29, 2020 ---
    Also, I found when using "on afk status change", a player only exits the afk status on move or on command events... not on chat event.
     
Loading...