1. Welcome to skUnity!

    Welcome to skUnity! This is a forum where members of the Skript community can communicate and interact. Skript Resource Creators can post their Resources for all to see and use.

    If you haven't done so already, feel free to join our official Discord server to expand your level of interaction with the comminuty!

    Now, what are you waiting for? Join the community now!

  2. LOOKING FOR A VERSION OF SKRIPT?

    You can always check out our Wiki for downloads and any other information about Skript!

Dismiss Notice
This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

%Player's Prefix% or so, not working correctly

Discussion in 'Skript' started by Freddols, Feb 3, 2017.

Thread Status:
Not open for further replies.
  1. Freddols

    Freddols New Member

    Joined:
    Jan 26, 2017
    Messages:
    6
    Likes Received:
    0
    Hello There!

    So, as the title describes, expressions such as %Player's Suffix% Or %Player's Display Name%, Do not work correctly. On strings, like messages, or Broadcasts, they don't have any color but just show up as plain white, and look something like this:

    &c&lOWNER &r&c

    I have tried putting it in a variable first, but that does not seem to help in any way.
    Now, im not sure but this may be the cause of the version. i use Skript Version 2.2 V8b.

    If you need any more information on this problem (As i have no other thing that i can really say here), Please tell me in the Replies.

    Thanks!
     
  2. ShaneBee

    Moderator Resource Staff Supporter + Addon Developer

    Joined:
    Sep 7, 2017
    Messages:
    2,184
    Likes Received:
    225
    Have you tried %colored player's prefix%? Using "colored" will parse color codes in a string and return it properly colored.

    It's weird that you have to do that though; on my server the prefix & suffix return properly colored. Are you sure you have a proper version of Vault & a chat plugin installed correctly?
     
  3. ShaneBee

    Moderator Resource Staff Supporter + Addon Developer

    Joined:
    Sep 7, 2017
    Messages:
    2,184
    Likes Received:
    225
    Yes, the other plugins are all updated. I will use ur technique later, Thanks!
     
  4. ShaneBee

    Moderator Resource Staff Supporter + Addon Developer

    Joined:
    Sep 7, 2017
    Messages:
    2,184
    Likes Received:
    225
    Try:
    %coloured player's prefix%
     
  5. ShaneBee

    Moderator Resource Staff Supporter + Addon Developer

    Joined:
    Sep 7, 2017
    Messages:
    2,184
    Likes Received:
    225
    That was already said (by me), you should read replies on posts to make sure you're not just repeating stuff.
     
  6. ShaneBee

    Moderator Resource Staff Supporter + Addon Developer

    Joined:
    Sep 7, 2017
    Messages:
    2,184
    Likes Received:
    225
    ou said "colored" and that does not work for me
    %coloured player's prefix%
    Is working fine
    You seem to be looking for confusion.
     
  7. ShaneBee

    Moderator Resource Staff Supporter + Addon Developer

    Joined:
    Sep 7, 2017
    Messages:
    2,184
    Likes Received:
    225
    • Agree Agree x 2
Thread Status:
Not open for further replies.

Share This Page

Loading...