1. Welcome to skUnity!

    Welcome to skUnity! This is a forum where members of the Skript community can communicate and interact. Skript Resource Creators can post their Resources for all to see and use.

    If you haven't done so already, feel free to join our official Discord server to expand your level of interaction with the comminuty!

    Now, what are you waiting for? Join the community now!

  2. LOOKING FOR A VERSION OF SKRIPT?

    You can always check out our Wiki for downloads and any other information about Skript!

Dismiss Notice
This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Error loading variables.

Discussion in 'Skript' started by KJPAKA, Aug 1, 2020 at 5:13 AM.

Tags:
  1. KJPAKA

    KJPAKA Member

    Joined:
    Feb 21, 2020
    Messages:
    1
    Likes Received:
    0
    Information:

    Hello, I have had this issue for a couple of months now its been on and off and I don't know what triggers it so I finally decided to make a forum post explaining my issue. So whenever I start/restart my server it won't load some variables saved from the session before the start/restart. However, I'm confused because it doesn't say why it can't load them and that's where I am at this point.

    Log Errors:


    Code (Text):
    1. [02:57:32] [Server thread/ERROR]: #!#!
    2. [02:57:32] [Server thread/ERROR]: #!#! ===!!!=== Skript variable load error ===!!!===
    3. [02:57:32] [Server thread/ERROR]: #!#! Unable to load (all) variables:
    4. [02:57:32] [Server thread/ERROR]: #!#! 1 variable could not be loaded!
    5. [02:57:32] [Server thread/ERROR]: #!#! Affected variables: gens::59d6b85a-2bb9-420c-9860-bfa6e18ad625::stone::1
    6. [02:57:32] [Server thread/INFO]: [Skript] Created a backup of variables.csv as variables_2020-08-01_02-57-32.csv
    7. [02:57:32] [Server thread/ERROR]: #!#!
    8. [02:57:32] [Server thread/ERROR]: #!#! Skript will work properly, but old variables might not be available at all and new ones may or may not be saved until Skript is able to create a backup of the old file and/or is able to connect to the database (which requires a restart of Skript)!
    9. [02:57:32] [Server thread/ERROR]: #!#! `
    Other Useful Info:

    I'm using 1.16.1 server on minehut.

    Addons using (including versions):
    TuSKe, SkQuery, skRayFall, Skellet, and SkBee.

    Troubleshooting:

    Have you tried searching the docs? Yes
    Have you tried searching the forums? Yes
    What other methods have you tried to fix it? Nothing, as I don't know what to fix. (I did send the logs to friends but they had no idea)
    --- Double Post Merged, Aug 2, 2020 at 2:49 AM, Original Post Date: Aug 1, 2020 at 5:13 AM ---
    .
    --- Double Post Merged, Aug 2, 2020 at 2:50 AM ---
    Even if you don't know please leave suggestions on how I can fix this. Thanks!
     
Loading...