1. Welcome to skUnity!

    Welcome to skUnity! This is a forum where members of the Skript community can communicate and interact. Skript Resource Creators can post their Resources for all to see and use.

    If you haven't done so already, feel free to join our official Discord server to expand your level of interaction with the comminuty!

    Now, what are you waiting for? Join the community now!

  2. LOOKING FOR A VERSION OF SKRIPT??:

    You can always check our our Wiki for downloads and any other information about Skript!

Dismiss Notice
This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Solved Colours is not working

Discussion in 'Skript' started by Keynadi, Jan 27, 2019.

Thread Status:
Not open for further replies.
  1. Keynadi

    Keynadi Member

    Joined:
    Aug 29, 2018
    Messages:
    5
    Likes Received:
    0
    So, I have a code from https://forums.skunity.com/resources/iessentials.425/

    command /gmc [<player>]:
    aliases: creative
    permission: gamemode.creative
    permission message: &cYou do not have permission for this command!
    trigger:
    if argument 1 is not set:
    set player's gamemode to creative
    message "&6Set game mode &ccreative &6for %player's display name%&6." to sender
    else:
    argument 1 is online
    if sender has permission "gamemode.creative.others":
    set argument 1's gamemode to creative
    message "&6Set game mode &ccreative &6for %player's display name%&6." to sender
    else:
    message "&cYou do not have permission for this command!" to sender

    and for some reason "permission message: &cYou do not have permission for this command!" is not colored. the example is on a screenshot. Is it a bug or I'm just dumb? Paper 1.13.2 Screenshot_1014.png
     
  2. TPGamesNL

    Supporter

    Joined:
    Jan 20, 2018
    Messages:
    1,380
    Likes Received:
    85
    Medals:
    Update Skript, this was a bug before dev37c
     
    • Like Like x 1
  3. Keynadi

    Keynadi Member

    Joined:
    Aug 29, 2018
    Messages:
    5
    Likes Received:
    0
  4. ShaneBee

    Resource Staff Supporter + Addon Developer

    Joined:
    Sep 7, 2017
    Messages:
    2,124
    Likes Received:
    164
    Its a bug that they already know about
    For the time being you can use the symbol `§` instead of `&` for colored permission messages
     
  5. Keynadi

    Keynadi Member

    Joined:
    Aug 29, 2018
    Messages:
    5
    Likes Received:
    0
    Screenshot_1015.png
    Same
    I already tried <red> and \u00A7c they are not working
    --- Double Post Merged, Jan 28, 2019, Original Post Date: Jan 28, 2019 ---
    Oh, now it's working. You need to use UTF-8 not ANSI, but I used ANSI. Thank you for help
     
  6. ShaneBee

    Resource Staff Supporter + Addon Developer

    Joined:
    Sep 7, 2017
    Messages:
    2,124
    Likes Received:
    164
    You're welcome
     
Thread Status:
Not open for further replies.
Loading...