1. Welcome to skUnity!

    Welcome to skUnity! This is a forum where members of the Skript community can communicate and interact. Skript Resource Creators can post their Resources for all to see and use.

    If you haven't done so already, feel free to join our official Discord server to expand your level of interaction with the comminuty!

    Now, what are you waiting for? Join the community now!

  2. LOOKING FOR A VERSION OF SKRIPT?

    You can always check out our Wiki for downloads and any other information about Skript!

Dismiss Notice
This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Solved Tablist Header and footer

Discussion in 'Skript' started by Runakai, May 1, 2018.

Tags:
Thread Status:
Not open for further replies.
  1. Runakai

    Moderator Supporter

    Joined:
    Apr 27, 2018
    Messages:
    489
    Likes Received:
    28
    Hello, you should already know me. :emoji_grinning:

    Code (Skript):
    1.  
    2. on join:
    3.     set header to "&3Bienvenue sur &6Amonia !" for player-event
    4.  
    No errors. Does not work no errors but in console
    Code (Skript):
    1.  
    2. on join:
    3.     set header to "&3Bienvenue sur &6Amonia !" for player
    4.  
    Also does not work no errors. (but in console)

    [21:08:02 ERROR]: #!#!
    [21:08:02 ERROR]: #!#! [Skript] Severe Error:
    [21:08:02 ERROR]: #!#! Could not load tablist.sk
    [21:08:02 ERROR]: #!#!
    [21:08:02 ERROR]: #!#! Something went horribly wrong with Skript.
    [21:08:02 ERROR]: #!#! This issue is NOT your fault! You probably can't fix it yourself, either.
    [21:08:02 ERROR]: #!#! Your Minecraft version or server software appears to be unsupported by Skript (bensku's version).
    [21:08:02 ERROR]: #!#! Currently only supported servers are Spigot and its forks for Minecraft 1.9 or newer.
    [21:08:02 ERROR]: #!#! Other versions might work, but since you're getting this error message something is NOT working,
    [21:08:02 ERROR]: #!#! nor it will work, unless you switch to supported platform.
    [21:08:02 ERROR]: #!#! Issue tracker: https://github.com/bensku/Skript/issues (only if you know what you're doing!)
    [21:08:02 ERROR]: #!#!
    [21:08:02 ERROR]: #!#! Stack trace:
    [21:08:02 ERROR]: #!#! ch.njol.skript.SkriptAPIException: No class info found for player'
    [21:08:02 ERROR]: #!#! at ch.njol.skript.registrations.Classes.getClassInfo(Classes.java:263)
    [21:08:02 ERROR]: #!#! at ch.njol.skript.lang.SkriptParser.createExprInfo(SkriptParser.java:1804)
    [21:08:02 ERROR]: #!#! at ch.njol.skript.lang.SkriptParser.getExprInfo(SkriptParser.java:1771)
    [21:08:02 ERROR]: #!#! at ch.njol.skript.lang.SkriptParser.parse_i(SkriptParser.java:1519)
    [21:08:02 ERROR]: #!#! at ch.njol.skript.lang.SkriptParser.parse(SkriptParser.java:225)
    [21:08:02 ERROR]: #!#! at ch.njol.skript.lang.SkriptParser.parse(SkriptParser.java:180)
    [21:08:02 ERROR]: #!#! at ch.njol.skript.lang.Statement.parse(Statement.java:59)
    [21:08:02 ERROR]: #!#! at ch.njol.skript.ScriptLoader.loadItems(ScriptLoader.java:969)
    [21:08:02 ERROR]: #!#! at ch.njol.skript.ScriptLoader.loadScript(ScriptLoader.java:662)
    [21:08:02 ERROR]: #!#! at ch.njol.skript.ScriptLoader.lambda$1(ScriptLoader.java:389)
    [21:08:02 ERROR]: #!#! at ch.njol.skript.ScriptLoader.loadScripts(ScriptLoader.java:401)
    [21:08:02 ERROR]: #!#! at ch.njol.skript.ScriptLoader.loadScripts(ScriptLoader.java:434)
    [21:08:02 ERROR]: #!#! at ch.njol.skript.SkriptCommand.onCommand(SkriptCommand.java:188)
    [21:08:02 ERROR]: #!#! at org.bukkit.command.PluginCommand.execute(PluginCommand.java:44)
    [21:08:02 ERROR]: #!#! at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:141)
    [21:08:02 ERROR]: #!#! at org.bukkit.craftbukkit.v1_8_R3.CraftServer.dispatchCommand(CraftServer.java:641)
    [21:08:02 ERROR]: #!#! at net.minecraft.server.v1_8_R3.PlayerConnection.handleCommand(PlayerConnection.java:1162)
    [21:08:02 ERROR]: #!#! at net.minecraft.server.v1_8_R3.PlayerConnection.a(PlayerConnection.java:997)
    [21:08:02 ERROR]: #!#! at net.minecraft.server.v1_8_R3.PacketPlayInChat.a(PacketPlayInChat.java:45)
    [21:08:02 ERROR]: #!#! at net.minecraft.server.v1_8_R3.PacketPlayInChat.a(PacketPlayInChat.java:1)
    [21:08:02 ERROR]: #!#! at net.minecraft.server.v1_8_R3.PlayerConnectionUtils$1.run(SourceFile:13)
    [21:08:02 ERROR]: #!#! at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
    [21:08:02 ERROR]: #!#! at java.util.concurrent.FutureTask.run(FutureTask.java:266)
    [21:08:02 ERROR]: #!#! at net.minecraft.server.v1_8_R3.SystemUtils.a(SourceFile:44)
    [21:08:02 ERROR]: #!#! at net.minecraft.server.v1_8_R3.MinecraftServer.B(MinecraftServer.java:715)
    [21:08:02 ERROR]: #!#! at net.minecraft.server.v1_8_R3.DedicatedServer.B(DedicatedServer.java:374)
    [21:08:02 ERROR]: #!#! at net.minecraft.server.v1_8_R3.MinecraftServer.A(MinecraftServer.java:654)
    [21:08:02 ERROR]: #!#! at net.minecraft.server.v1_8_R3.MinecraftServer.run(MinecraftServer.java:557)
    [21:08:02 ERROR]: #!#! at java.lang.Thread.run(Thread.java:748)
    [21:08:02 ERROR]: #!#!
    [21:08:02 ERROR]: #!#! Version Information:
    [21:08:02 ERROR]: #!#! Skript: 2.2-dev35b (latest)
    [21:08:02 ERROR]: #!#! Bukkit: 1.8.8-R0.1-SNAPSHOT
    [21:08:02 ERROR]: #!#! Minecraft: 1.8.8
    [21:08:02 ERROR]: #!#! Java: 1.8.0_161 (Java HotSpot(TM) 64-Bit Server VM 25.161-b12)
    [21:08:02 ERROR]: #!#! OS: Linux amd64 3.16.0-4-amd64
    [21:08:02 ERROR]: #!#!
    [21:08:02 ERROR]: #!#! Server platform: Spigot
    [21:08:02 ERROR]: #!#!
    [21:08:02 ERROR]: #!#! Current node: set tab header to "header" and footer to "footer" for player (tablist.sk, line 2)
    [21:08:02 ERROR]: #!#! Current item: null
    [21:08:02 ERROR]: #!#!
    [21:08:02 ERROR]: #!#! Thread: Server thread
    [21:08:02 ERROR]: #!#!
    [21:08:02 ERROR]: #!#! Language: english
    [21:08:02 ERROR]: #!#! Link parse mode: DISABLED
    [21:08:02 ERROR]: #!#!
    [21:08:02 ERROR]: #!#! End of Error.
    [21:08:02 ERROR]: #!#!


     
    #1 Runakai, May 1, 2018
    Last edited: May 1, 2018
  2. Best Answer:
    Post #31 by ShaneBee, May 3, 2018
  3. ShaneBee

    Moderator Resource Staff Supporter + Addon Developer

    Joined:
    Sep 7, 2017
    Messages:
    2,185
    Likes Received:
    214
    try this
    Code (Skript):
    1. set tab header to "header" and footer to "footer" for player
    obviously edit header and footer to your liking
    --- Double Post Merged, May 1, 2018, Original Post Date: May 1, 2018 ---
    PS I BELIEVE the EFFECT I am using requires SkRayFall
     
  4. Runakai

    Moderator Supporter

    Joined:
    Apr 27, 2018
    Messages:
    489
    Likes Received:
    28
    I am running the latest version of RayFall and it does not work
     
  5. ShaneBee

    Moderator Resource Staff Supporter + Addon Developer

    Joined:
    Sep 7, 2017
    Messages:
    2,185
    Likes Received:
    214
    I am running Skript version 2.2 Dev 35b, with skRayFall version 1.9.12
    on Spigot 1.12.2
    I just tried this
    Code (Skript):
    1.  
    2. on join:
    3.     set tab header to "header" and footer to "footer" for player
    4.  
    and this is the result
    [​IMG]
     
  6. Runakai

    Moderator Supporter

    Joined:
    Apr 27, 2018
    Messages:
    489
    Likes Received:
    28
    Does not work for me :/
     
  7. ShaneBee

    Moderator Resource Staff Supporter + Addon Developer

    Joined:
    Sep 7, 2017
    Messages:
    2,185
    Likes Received:
    214
    Skript: 2.2-dev35b (latest)
    [21:08:02 ERROR]: #!#! Bukkit: 1.8.8-R0.1-SNAPSHOT


    Bensku's Skript is not supported on 1.8.8 also, Bensku's Skript does not work on Bukkit, it needs to be on either Spigot of PaperSpigot
     
  8. Runakai

    Moderator Supporter

    Joined:
    Apr 27, 2018
    Messages:
    489
    Likes Received:
    28
    W
    Well, it is a spigot server. But, anyways, where should i download skript then?
     
  9. ShaneBee

    Moderator Resource Staff Supporter + Addon Developer

    Joined:
    Sep 7, 2017
    Messages:
    2,185
    Likes Received:
    214
    Oh yes I see that now, sorry didn't see the spigot part on the other line.
    I personally have no clue how to do stuff on ancient server software. But I think you need an older version of Bensku's fork OR you need to download the ancient version of Skript from BUKKIT
     
  10. Runakai

    Moderator Supporter

    Joined:
    Apr 27, 2018
    Messages:
    489
    Likes Received:
    28
    So... I tried using the skript from bukkit. 200 Errors ingame and the tablist skript does not work.
     
  11. ShaneBee

    Moderator Resource Staff Supporter + Addon Developer

    Joined:
    Sep 7, 2017
    Messages:
    2,185
    Likes Received:
    214
    Yeah then I really have no clue. Unfortunately support for 1.8 MC is very limited as the Devs have been updating Skript for current MC software
    --- Double Post Merged, May 1, 2018, Original Post Date: May 1, 2018 ---
    Pikachu said "dev35 is fine, you just need paperspigot" So I guess I would suggest downloading paper spigot and giving that a try
     
  12. Runakai

    Moderator Supporter

    Joined:
    Apr 27, 2018
    Messages:
    489
    Likes Received:
    28
    :emoji_frowning:
     
  13. ShaneBee

    Moderator Resource Staff Supporter + Addon Developer

    Joined:
    Sep 7, 2017
    Messages:
    2,185
    Likes Received:
    214
    Im not sure why the frowny face, give PaperSpigot a try :emoji_slight_smile:
     
  14. Runakai

    Moderator Supporter

    Joined:
    Apr 27, 2018
    Messages:
    489
    Likes Received:
    28

    Well, thats gonna be a big proglem. My Hoster does not support paper spigot :emoji_astonished:
     
  15. ShaneBee

    Moderator Resource Staff Supporter + Addon Developer

    Joined:
    Sep 7, 2017
    Messages:
    2,185
    Likes Received:
    214
    Oh... well I would suggest sending them a message and asking them to support Paper Spigot since its a for OF spigot
     
  16. Uzumaki

    Uzumaki Well-Known Member

    Joined:
    Feb 20, 2017
    Messages:
    292
    Likes Received:
    8
    use skript dev27.
     
  17. Runakai

    Moderator Supporter

    Joined:
    Apr 27, 2018
    Messages:
    489
    Likes Received:
    28
    So, i installed Paperspigot and it still does not work
     
  18. ShaneBee

    Moderator Resource Staff Supporter + Addon Developer

    Joined:
    Sep 7, 2017
    Messages:
    2,185
    Likes Received:
    214
    Upload your complete skript file here. using the Upload a File button bellow.
    I want to see everything in your skript so I can hopefully help figure this out for you
     
  19. ShaneBee

    Moderator Resource Staff Supporter + Addon Developer

    Joined:
    Sep 7, 2017
    Messages:
    2,185
    Likes Received:
    214
    Its not working, when I open it, it unzips into another zip file, which opens into another zip file, and keeps doing that
    --- Double Post Merged, May 3, 2018, Original Post Date: May 3, 2018 ---
    OK, i got it to work, used a different unzipper!
    --- Double Post Merged, May 3, 2018 ---
    Ok, so you had THIS in your tablist.sk
    Code (Skript):
    1. on join:
    2.     set {_P} to player parsed as offline player
    3.     set tab header to "header" and footer to "footer" for {_P}
    4.  
    I have no clue what you were trying to do there, but that does not work,
    If you do this it'll work
    Code (Skript):
    1. on join:
    2.     set tab header to "header" and footer to "footer" for player
    3.  
     
  20. Runakai

    Moderator Supporter

    Joined:
    Apr 27, 2018
    Messages:
    489
    Likes Received:
    28
    Well, i was using YOUR code before and it didn't work. So i tried doing something. lol.
     
  21. ShaneBee

    Moderator Resource Staff Supporter + Addon Developer

    Joined:
    Sep 7, 2017
    Messages:
    2,185
    Likes Received:
    214
    Oh, try this new one and see if it works, I ran it on my test server and it works fine
     
Thread Status:
Not open for further replies.

Share This Page

Loading...