1. Welcome to skUnity!

    Welcome to skUnity! This is a forum where members of the Skript community can communicate and interact. Skript Resource Creators can post their Resources for all to see and use.

    If you haven't done so already, feel free to join our official Discord server to expand your level of interaction with the comminuty!

    Now, what are you waiting for? Join the community now!

Dismiss Notice
This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Addon SkVault (Skript Economy Registerer) 1.2

Make your custom Skript economy Vault compatible!

  1. Donut

    Addon Developer

    Joined:
    Mar 27, 2017
    Messages:
    1,340
    Likes Received:
    175
    Medals:
    Donut submitted a new resource:

    SkVault (Custom Economy Support) - Make your custom Skript economy Vault compatible!

    Read more about this resource...
     
  2. Donut

    Addon Developer

    Joined:
    Mar 27, 2017
    Messages:
    1,340
    Likes Received:
    175
    Medals:
    Donut updated SkVault (Custom Economy Support) with a new update entry:

    Version 1.0.5

    Read the rest of this update entry...
     
  3. Donut

    Addon Developer

    Joined:
    Mar 27, 2017
    Messages:
    1,340
    Likes Received:
    175
    Medals:
    Donut updated SkVault (Custom Economy Support) with a new update entry:

    Version 1.1

    Read the rest of this update entry...
     
  4. Donut

    Addon Developer

    Joined:
    Mar 27, 2017
    Messages:
    1,340
    Likes Received:
    175
    Medals:
  5. Donut

    Addon Developer

    Joined:
    Mar 27, 2017
    Messages:
    1,340
    Likes Received:
    175
    Medals:
  6. Hakim

    Hakim Member

    Joined:
    Mar 22, 2017
    Messages:
    13
    Likes Received:
    0
    java.lang.UnsupportedOperationException: EconomyNameRequest
    uhhh can't load other plugins requiring economy
    on vault economy name request:
    return "CC"
    --- Double Post Merged, Sep 24, 2018, Original Post Date: Sep 24, 2018 ---
    i assume this is cause the skript isn't loaded yet maybe add a default value?
     
  7. ShaneBee

    Supporter + Addon Developer

    Joined:
    Sep 7, 2017
    Messages:
    2,055
    Likes Received:
    144
    Which version of Skript are you using?
    Which version of SkVault are you using?
    Which version of Vault are you using?
    Which server software/version are you using?
     
  8. Hakim

    Hakim Member

    Joined:
    Mar 22, 2017
    Messages:
    13
    Likes Received:
    0
    Shit totally forgot about this
    Skript - Fixes V8
    SkVault - 1.2
    Vault - 1.5.6-b49
    Server - Paperspigot 1.7
     
  9. ShaneBee

    Supporter + Addon Developer

    Joined:
    Sep 7, 2017
    Messages:
    2,055
    Likes Received:
    144
    OOF .... 1.7 may be the problem, I guess @Donut will be needed to answer that. I don't know if his plugin will work on 1.7 or not
     
  10. Hakim

    Hakim Member

    Joined:
    Mar 22, 2017
    Messages:
    13
    Likes Received:
    0
    I don't think so according to the error but maybe.
     
  11. Donut

    Addon Developer

    Joined:
    Mar 27, 2017
    Messages:
    1,340
    Likes Received:
    175
    Medals:
    i have no intention of supporting outdated server/plugin versions. If you can reproduce the error with up to date versions of everything id be happy to help
     
    • Like Like x 1
  12. Hakim

    Hakim Member

    Joined:
    Mar 22, 2017
    Messages:
    13
    Likes Received:
    0
    Im using Fe right now so problem resolved, anyways just wondering do you help 1.8 users then?
    --- Double Post Merged, Sep 27, 2018, Original Post Date: Sep 27, 2018 ---
    also
    "Version 1.2
    - Fixed error when using older Skript versions"
     
  13. ShaneBee

    Supporter + Addon Developer

    Joined:
    Sep 7, 2017
    Messages:
    2,055
    Likes Received:
    144
    That is referring to oldver versions of skript, the plugin, not older server versions.
     
  14. Hakim

    Hakim Member

    Joined:
    Mar 22, 2017
    Messages:
    13
    Likes Received:
    0
     
  15. ShaneBee

    Supporter + Addon Developer

    Joined:
    Sep 7, 2017
    Messages:
    2,055
    Likes Received:
    144
    ""i have no intention of supporting outdated server/plugin versions.""
    ""- Fixed error when using older Skript versions"""

    Outdated and Older are two different things.

    Ie: We are currently on Skript (benskus fork) 2.2 dev37c
    so something like dev27 would be considered "Older"

    you are on Mirreski's fork Skript - Fixes V8, that would be considered outdated!
     
    • Agree Agree x 1
  16. Donut

    Addon Developer

    Joined:
    Mar 27, 2017
    Messages:
    1,340
    Likes Received:
    175
    Medals:
    exactly what shane said, an api change was made in dev32 that i initially overlooked. dev32 is a hell of a lot more recent than mirreski's fork.

    as for your question "do you help 1.8 users then?" if the issue is caused by 1.8, no i wont waste my time fixing it (unless its a simple fix). if the issue is not because of 1.8, of course i will address it. all i ask is that people reproduce errors with up to date versions since like i said, im not gonna waste my time figuring out if thats the reason
     
    • Agree Agree x 1
  17. Hakim

    Hakim Member

    Joined:
    Mar 22, 2017
    Messages:
    13
    Likes Received:
    0
    Understandable, thank you.
     
Loading...