I keep getting the same error with TuSKe

  • Welcome to skUnity!

    Welcome to skUnity! This is a forum where members of the Skript community can communicate and interact. Skript Resource Creators can post their Resources for all to see and use.

    If you haven't done so already, feel free to join our official Discord server to expand your level of interaction with the comminuty!

    Now, what are you waiting for? Join the community now!

  • LOOKING FOR A VERSION OF SKRIPT?

    You can always check out our Wiki for downloads and any other information about Skript!

Status
Not open for further replies.

JustTitan

Member
Sep 23, 2018
2
1
0
32
I'm trying to make a simple ban GUI using the Skript addon TuSKe. I've tried finding the solution to my problem but everything I find gives me the same error. It opens the menu for me but the item doesn't show up.
code_language.skript:
command /sban [<text>]:
    permission: staff.sban
    permission message: &c&lYou can't use this command.
    trigger:
        if arg 1 is set:
            open virtual chest inventory with size 6 named "&c&lBan %arg-1%" to player
            wait 1 tick
            format gui slot 4 of player with diamond named "&eTesting" to run player command "/say hi"
        if arg 1 is not set:
            send "&7[&cSBan&7] &6Usage: /Sban <Player>"

Here is the error message -
2018-09-23_13.59.23.png
 
I have Skellett and SkQuery in my server, and now I installed TuSKe
Code working for me:
code_language.skript:
command /sban [<text>]:
    permission: staff.sban
    permission message: &c&lYou can't use this command.
    trigger:
        if arg 1 is set:
            open chest with 6 rows named "&c&lBan %arg-1%" to player
            wait 1 tick
            format slot 4 of player with diamond named "&eTesting" to close then run "bc hi"
        if arg 1 is not set:
            send "&7[&cSBan&7] &6Usage: /Sban <Player>"

The problem is with "to close then run player command", you just can't execute a command with the player like this.
This runs /bc hi with console.. Idk how to run command with player.
[doublepost=1537727752,1537727559][/doublepost]Its working without SkQuery and Skellett.
 
I'm trying to make a simple ban GUI using the Skript addon TuSKe. I've tried finding the solution to my problem but everything I find gives me the same error. It opens the menu for me but the item doesn't show up.
code_language.skript:
command /sban [<text>]:
    permission: staff.sban
    permission message: &c&lYou can't use this command.
    trigger:
        if arg 1 is set:
            open virtual chest inventory with size 6 named "&c&lBan %arg-1%" to player
            wait 1 tick
            format gui slot 4 of player with diamond named "&eTesting" to run player command "/say hi"
        if arg 1 is not set:
            send "&7[&cSBan&7] &6Usage: /Sban <Player>"

Here is the error message -
View attachment 2776
Hey I just tried this and I got no errors when reloading.
Which version of Skript are you running and which version of TuSKe?
 
Hey I just tried this and I got no errors when reloading.
Which version of Skript are you running and which version of TuSKe?
Hello, I tried the code too and... I got the same error message can't understand this condition/effect....
I have 2.2-dev37c and server version is 1.12.2
I have TuSKe v1.8.2
Btw I need this gui thing too for a script...:c

EDIT: Oh wait it worked.. lol
 
Hello, I tried the code too and... I got the same error message can't understand this condition/effect....
I have 2.2-dev37c and server version is 1.12.2
I have TuSKe v1.8.2
Btw I need this gui thing too for a script...:c
Are you getting errors from tuske when your server loads?
Since Tuske 1.8.2 doesn't load on dev37c..... you will need Tuske 1.8.3 Pikachu Patch 3
 
Are you getting errors from tuske when your server loads?
Since Tuske 1.8.2 doesn't load on dev37c..... you will need Tuske 1.8.3 Pikachu Patch 3
I get errors when the server loads, but the script is working.
Java:
[20:38:06 ERROR]: #!#!
[20:38:06 ERROR]: #!#! [Skript] Severe Error:
[20:38:06 ERROR]: #!#! TuSKe's class com.github.tukenuke.tuske.effects.EffMakeDrop generated an exception while loading
[20:38:06 ERROR]: #!#!
[20:38:06 ERROR]: #!#! Something went horribly wrong with Skript.
[20:38:06 ERROR]: #!#! This issue is NOT your fault! You probably can't fix it yourself, either.
[20:38:06 ERROR]: #!#! It looks like you are using some plugin(s) that alter how Skript works (addons).
[20:38:06 ERROR]: #!#! Following plugins are probably related to this error in some way:
[20:38:06 ERROR]: #!#! TuSKe (github.com/Tuke-Nuke/TuSKe)
[20:38:06 ERROR]: #!#! You should try disabling those plugins one by one, trying to find which one causes it.
[20:38:06 ERROR]: #!#! If the error doesn't disappear even after disabling all listed plugins, it is probably Skript issue.
[20:38:06 ERROR]: #!#! In that case, you will be given instruction on how should you report it.
[20:38:06 ERROR]: #!#! On the other hand, if the error disappears when disabling some plugin, report it to author of that plugin.
[20:38:06 ERROR]: #!#! Only if the author tells you to do so, report it as Skript issue (url below)
[20:38:06 ERROR]: #!#! Issue tracker: https://github.com/SkriptLang/Skript/issues (only if you know what you're doing!)
[20:38:06 ERROR]: #!#!
[20:38:06 ERROR]: #!#! Stack trace:
[20:38:06 ERROR]: #!#! java.lang.NullPointerException
[20:38:06 ERROR]: #!#!     at com.github.tukenuke.tuske.effects.EffMakeDrop.<clinit>(EffMakeDrop.java:25)
[20:38:06 ERROR]: #!#!     at java.lang.Class.forName0(Native Method)
[20:38:06 ERROR]: #!#!     at java.lang.Class.forName(Unknown Source)
[20:38:06 ERROR]: #!#!     at ch.njol.skript.SkriptAddon.loadClasses(SkriptAddon.java:107)
[20:38:06 ERROR]: #!#!     at com.github.tukenuke.tuske.TuSKe.onEnable(TuSKe.java:100)
[20:38:06 ERROR]: #!#!     at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:264)
[20:38:06 ERROR]: #!#!     at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:337)
[20:38:06 ERROR]: #!#!     at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:403)
[20:38:06 ERROR]: #!#!     at org.bukkit.craftbukkit.v1_12_R1.CraftServer.enablePlugin(CraftServer.java:381)
[20:38:06 ERROR]: #!#!     at org.bukkit.craftbukkit.v1_12_R1.CraftServer.enablePlugins(CraftServer.java:330)
[20:38:06 ERROR]: #!#!     at net.minecraft.server.v1_12_R1.MinecraftServer.t(MinecraftServer.java:422)
[20:38:06 ERROR]: #!#!     at net.minecraft.server.v1_12_R1.MinecraftServer.l(MinecraftServer.java:383)
[20:38:06 ERROR]: #!#!     at net.minecraft.server.v1_12_R1.MinecraftServer.a(MinecraftServer.java:338)
[20:38:06 ERROR]: #!#!     at net.minecraft.server.v1_12_R1.DedicatedServer.init(DedicatedServer.java:272)
[20:38:06 ERROR]: #!#!     at net.minecraft.server.v1_12_R1.MinecraftServer.run(MinecraftServer.java:545)
[20:38:06 ERROR]: #!#!     at java.lang.Thread.run(Unknown Source)
[20:38:06 ERROR]: #!#!
[20:38:06 ERROR]: #!#! Version Information:
[20:38:06 ERROR]: #!#!   Skript: 2.2-dev37c
[20:38:06 ERROR]: #!#!   Bukkit: 1.12.2-R0.1-SNAPSHOT
[20:38:06 ERROR]: #!#!   Minecraft: 1.12.2
[20:38:06 ERROR]: #!#!   Java: 1.8.0_181 (Java HotSpot(TM) 64-Bit Server VM 25.181-b13)
[20:38:06 ERROR]: #!#!   OS: Windows 10 amd64 10.0
[20:38:06 ERROR]: #!#!
[20:38:06 ERROR]: #!#! Server platform: Spigot
[20:38:06 ERROR]: #!#!
[20:38:06 ERROR]: #!#! Current node: null
[20:38:06 ERROR]: #!#! Current item: null
[20:38:06 ERROR]: #!#!
[20:38:06 ERROR]: #!#! Thread: Server thread
[20:38:06 ERROR]: #!#!
[20:38:06 ERROR]: #!#! Language: english
[20:38:06 ERROR]: #!#! Link parse mode: DISABLED
[20:38:06 ERROR]: #!#!
[20:38:06 ERROR]: #!#! End of Error.
[20:38:06 ERROR]: #!#!
 
I get errors when the server loads, but the script is working.
Java:
[20:38:06 ERROR]: #!#!
[20:38:06 ERROR]: #!#! [Skript] Severe Error:
[20:38:06 ERROR]: #!#! TuSKe's class com.github.tukenuke.tuske.effects.EffMakeDrop generated an exception while loading
[20:38:06 ERROR]: #!#!
[20:38:06 ERROR]: #!#! Something went horribly wrong with Skript.
[20:38:06 ERROR]: #!#! This issue is NOT your fault! You probably can't fix it yourself, either.
[20:38:06 ERROR]: #!#! It looks like you are using some plugin(s) that alter how Skript works (addons).
[20:38:06 ERROR]: #!#! Following plugins are probably related to this error in some way:
[20:38:06 ERROR]: #!#! TuSKe (github.com/Tuke-Nuke/TuSKe)
[20:38:06 ERROR]: #!#! You should try disabling those plugins one by one, trying to find which one causes it.
[20:38:06 ERROR]: #!#! If the error doesn't disappear even after disabling all listed plugins, it is probably Skript issue.
[20:38:06 ERROR]: #!#! In that case, you will be given instruction on how should you report it.
[20:38:06 ERROR]: #!#! On the other hand, if the error disappears when disabling some plugin, report it to author of that plugin.
[20:38:06 ERROR]: #!#! Only if the author tells you to do so, report it as Skript issue (url below)
[20:38:06 ERROR]: #!#! Issue tracker: https://github.com/SkriptLang/Skript/issues (only if you know what you're doing!)
[20:38:06 ERROR]: #!#!
[20:38:06 ERROR]: #!#! Stack trace:
[20:38:06 ERROR]: #!#! java.lang.NullPointerException
[20:38:06 ERROR]: #!#!     at com.github.tukenuke.tuske.effects.EffMakeDrop.<clinit>(EffMakeDrop.java:25)
[20:38:06 ERROR]: #!#!     at java.lang.Class.forName0(Native Method)
[20:38:06 ERROR]: #!#!     at java.lang.Class.forName(Unknown Source)
[20:38:06 ERROR]: #!#!     at ch.njol.skript.SkriptAddon.loadClasses(SkriptAddon.java:107)
[20:38:06 ERROR]: #!#!     at com.github.tukenuke.tuske.TuSKe.onEnable(TuSKe.java:100)
[20:38:06 ERROR]: #!#!     at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:264)
[20:38:06 ERROR]: #!#!     at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:337)
[20:38:06 ERROR]: #!#!     at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:403)
[20:38:06 ERROR]: #!#!     at org.bukkit.craftbukkit.v1_12_R1.CraftServer.enablePlugin(CraftServer.java:381)
[20:38:06 ERROR]: #!#!     at org.bukkit.craftbukkit.v1_12_R1.CraftServer.enablePlugins(CraftServer.java:330)
[20:38:06 ERROR]: #!#!     at net.minecraft.server.v1_12_R1.MinecraftServer.t(MinecraftServer.java:422)
[20:38:06 ERROR]: #!#!     at net.minecraft.server.v1_12_R1.MinecraftServer.l(MinecraftServer.java:383)
[20:38:06 ERROR]: #!#!     at net.minecraft.server.v1_12_R1.MinecraftServer.a(MinecraftServer.java:338)
[20:38:06 ERROR]: #!#!     at net.minecraft.server.v1_12_R1.DedicatedServer.init(DedicatedServer.java:272)
[20:38:06 ERROR]: #!#!     at net.minecraft.server.v1_12_R1.MinecraftServer.run(MinecraftServer.java:545)
[20:38:06 ERROR]: #!#!     at java.lang.Thread.run(Unknown Source)
[20:38:06 ERROR]: #!#!
[20:38:06 ERROR]: #!#! Version Information:
[20:38:06 ERROR]: #!#!   Skript: 2.2-dev37c
[20:38:06 ERROR]: #!#!   Bukkit: 1.12.2-R0.1-SNAPSHOT
[20:38:06 ERROR]: #!#!   Minecraft: 1.12.2
[20:38:06 ERROR]: #!#!   Java: 1.8.0_181 (Java HotSpot(TM) 64-Bit Server VM 25.181-b13)
[20:38:06 ERROR]: #!#!   OS: Windows 10 amd64 10.0
[20:38:06 ERROR]: #!#!
[20:38:06 ERROR]: #!#! Server platform: Spigot
[20:38:06 ERROR]: #!#!
[20:38:06 ERROR]: #!#! Current node: null
[20:38:06 ERROR]: #!#! Current item: null
[20:38:06 ERROR]: #!#!
[20:38:06 ERROR]: #!#! Thread: Server thread
[20:38:06 ERROR]: #!#!
[20:38:06 ERROR]: #!#! Language: english
[20:38:06 ERROR]: #!#! Link parse mode: DISABLED
[20:38:06 ERROR]: #!#!
[20:38:06 ERROR]: #!#! End of Error.
[20:38:06 ERROR]: #!#!
yeah that means you have to update tuske, thats why its not working for you
 
Are you getting errors from tuske when your server loads?
Since Tuske 1.8.2 doesn't load on dev37c..... you will need Tuske 1.8.3 Pikachu Patch 3
I do happen to be getting errors when the server starts up.

EDIT - I got this working by getting the latest version of skript. Thank you for the help. :emoji_stuck_out_tongue:
 

Attachments

  • error.png
    error.png
    140.7 KB · Views: 384
Last edited:
  • Like
Reactions: Scholler
Status
Not open for further replies.