1. Welcome to skUnity!

    Welcome to skUnity! This is a forum where members of the Skript community can communicate and interact. Skript Resource Creators can post their Resources for all to see and use.

    If you haven't done so already, feel free to join our official Discord server to expand your level of interaction with the comminuty!

    Now, what are you waiting for? Join the community now!

Dismiss Notice
This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Addon SkUniversal 2.6

Skript addon that provides support for a variety of plugins.

Tags:
  1. b
    bugreports
    5/5,
    Version: 2.6
    I only tried with AdvancedBan (need to check if player is muted for my chatsystem) and it works really good! only problem i have is: after the mute-duration expired, the chat looks like a normal vanilla chat (<playername> message). Once the player wrote a message like that, its normal again (chatsystem works again). (sry for my bad english i hope you can understand what i wrote lol) The console shows this error:

    [14:44:44 ERROR]: #!#!
    [14:44:44 ERROR]: #!#! [Skript] Severe Error:
    [14:44:44 ERROR]: #!#!
    [14:44:44 ERROR]: #!#! If you're developing an add-on for Skript this likely means that you have done something wrong.
    [14:44:44 ERROR]: #!#! If you're a server admin however please go to https://github.com/bensku/Skript/issues/
    [14:44:44 ERROR]: #!#! and check whether this error has already been reported.
    [14:44:44 ERROR]: #!#! If not please create a new ticket with a meaningful title, copy & paste this whole error into it (or use paste service),
    [14:44:44 ERROR]: #!#! and describe what you did before it happened and/or what you think caused the error.
    [14:44:44 ERROR]: #!#! If you think that it's a trigger that's causing the error please post the trigger as well.
    [14:44:44 ERROR]: #!#! By following this guide fixing the error should be easy and done fast.
    [14:44:44 ERROR]: #!#!
    [14:44:44 ERROR]: #!#! Stack trace:
    [14:44:44 ERROR]: #!#! java.lang.IllegalStateException: RevokePunishmentEvent cannot be triggered asynchronously from primary server thread.
    [14:44:44 ERROR]: #!#! at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:482)
    [14:44:44 ERROR]: #!#! at me.leoko.advancedban.bukkit.BukkitMethods.callRevokePunishmentEvent(BukkitMethods.java:352)
    [14:44:44 ERROR]: #!#! at me.leoko.advancedban.utils.Punishment.delete(Punishment.java:208)
    [14:44:44 ERROR]: #!#! at me.leoko.advancedban.manager.PunishmentManager.getPunishments(PunishmentManager.java:99)
    [14:44:44 ERROR]: #!#! at me.leoko.advancedban.manager.PunishmentManager.getMute(PunishmentManager.java:171)
    [14:44:44 ERROR]: #!#! at me.leoko.advancedban.manager.PunishmentManager.isMuted(PunishmentManager.java:180)
    [14:44:44 ERROR]: #!#! at us._donut_.skuniversal.advancedban.conditions.CondMuted.check(CondMuted.java:46)
    [14:44:44 ERROR]: #!#! at ch.njol.skript.lang.Condition.run(Condition.java:58)
    [14:44:44 ERROR]: #!#! at ch.njol.skript.lang.Conditional.walk(Conditional.java:53)
    [14:44:44 ERROR]: #!#! at ch.njol.skript.lang.TriggerItem.walk(TriggerItem.java:93)
    [14:44:44 ERROR]: #!#! at ch.njol.skript.lang.Trigger.execute(Trigger.java:53)
    [14:44:44 ERROR]: #!#! at ch.njol.skript.events.EvtChat$1.execute(EvtChat.java:68)
    [14:44:44 ERROR]: #!#! at ch.njol.skript.events.EvtChat$1$1.call(EvtChat.java:87)
    [14:44:44 ERROR]: #!#! at ch.njol.skript.events.EvtChat$1$1.call(EvtChat.java:1)
    [14:44:44 ERROR]: #!#! at org.bukkit.craftbukkit.v1_8_R3.scheduler.CraftFuture.run(CraftFuture.java:89)
    [14:44:44 ERROR]: #!#! at org.bukkit.craftbukkit.v1_8_R3.scheduler.CraftScheduler.mainThreadHeartbeat(CraftScheduler.java:350)
    [14:44:44 ERROR]: #!#! at net.minecraft.server.v1_8_R3.MinecraftServer.B(MinecraftServer.java:723)
    [14:44:44 ERROR]: #!#! at net.minecraft.server.v1_8_R3.DedicatedServer.B(DedicatedServer.java:374)
    [14:44:44 ERROR]: #!#! at net.minecraft.server.v1_8_R3.MinecraftServer.A(MinecraftServer.java:654)
    [14:44:44 ERROR]: #!#! at net.minecraft.server.v1_8_R3.MinecraftServer.run(MinecraftServer.java:557)
    [14:44:44 ERROR]: #!#! at java.lang.Thread.run(Unknown Source)
    [14:44:44 ERROR]: #!#!
    [14:44:44 ERROR]: #!#! Version Information:
    [14:44:44 ERROR]: #!#! Skript: 2.2-dev25
    [14:44:44 ERROR]: #!#! Bukkit: 1.8.8-R0.1-SNAPSHOT
    [14:44:44 ERROR]: #!#! Minecraft: 1.8.8
    [14:44:44 ERROR]: #!#! Java: 1.8.0_221 (Java HotSpot(TM) 64-Bit Server VM 25.221-b11)
    [14:44:44 ERROR]: #!#! OS: Windows 10 amd64 10.0
    [14:44:44 ERROR]: #!#!
    [14:44:44 ERROR]: #!#! Running CraftBukkit: false
    [14:44:44 ERROR]: #!#!
    [14:44:44 ERROR]: #!#! Current node: null
    [14:44:44 ERROR]: #!#! Current item: playerthe player is muted
    [14:44:44 ERROR]: #!#!
    [14:44:44 ERROR]: #!#! Thread: Server thread
    [14:44:44 ERROR]: #!#!
    [14:44:44 ERROR]: #!#! End of Error.
  2. R
    Romitou
    5/5,
    Version: 2.6
    The creator is super nice, I'm new to Skript, and the creator was good to help me on many points that I did not understand on Discord with SkUniversal. (Sorry for my bad english, I'm french.)
  3. ShaneBee
    ShaneBee
    5/5,
    Version: 2.1
    Great add-on. Author is super awesome and helpful. Responds quickly to help, fixes things quickly as needed, and is open to adding new things in. Thanks a bunch donut for this add-on and your support
  4. Veraid
    Veraid
    5/5,
    Version: 2.0.5
    Very good! Hooks into many popular plugins and comes with some useful syntax for them
  5. EWS
    EWS
    5/5,
    Version: 1.5
    Wonderful addon! I have some suggestions:
    - Add a config to disable specific hooks, so you won't load syntaxes that are not necessary.
    - FastAsyncWorldEdit?
    1. Donut
      Author's Response
      It will only register syntaxes for plugins you have automatically (the hooked plugins are shown in console on server load or via the /skuniversal command). I'll look into FastAsyncWorldEdit.
  6. k
    kasper227232
    5/5,
    Version: 1.4
    Great addon, would it be possible to add support for GriefPrevention?
    1. Donut
  7. f
    feerko
    5/5,
    Version: 1.2
    Hello, your addon is awesome. Can you add support for FactionsUUID? SkRambled is outdated :(
    1. Donut
  8. JustADev
    JustADev
    5/5,
    Version: 1.2
    10/10 would highly recommend. But I would love it if you added aSkyblock plugin support bro. Nice work!
    1. Donut
  9. Ayham Alali
    Ayham Alali
    5/5,
    Version: 1.1.5
    I didn't use it yet, but looks very useful, hope you add more plugins support like.. MineCrates, PrisonMines, DeluxeChat, DeluxeTags.. specially those premium plugins :)
    Keep going mate <3
    1. Donut
      Author's Response
      More plugins are on the way!
  10. GrimEpp
    GrimEpp
    5/5,
    Version: 1.1.5
    Really good addon. There are so many addons around, and most them only make the same effects. It is really nice to have a hookup to so many plugins. +1
    1. Donut
      Author's Response
      Thanks for the feedback!
  11. P
    PuchiGFX
    5/5,
    Version: 1.1.5
    Nice addon! :D
    Idea: add cookloco's skywars support, i need it :-:
    1. Donut
      Author's Response
      Glad you like it! I should be able to add support for cookloco's skywars (next update will be in a couple weeks give or take, maybe sooner).
  12. Uzumaki
    Uzumaki
    5/5,
    Version: 1.1
    ----------------------------------------------
    Thanks for this Amazing addon.
    ----------------------------------------------
    1. Donut
      Author's Response
      Thanks for the review!